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COPYRIGHT 

© 2022 SAP SE or an SAP affiliate company. All rights reserved. 

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express 
permission of SAP SE or an SAP affiliate company. 

SAP and other SAP products and services mentioned herein as well as their respective logos are trademarks or 
registered trademarks of SAP SE (or an SAP affiliate company) in Germany and other countries. Please see 
http://global.sap.com/corporate-en/legal/copyright/index.epx#trademark for additional trademark information and notices. 

Some software products marketed by SAP SE and its distributors contain proprietary software components of other 
software vendors. 

National product specifications may vary. 

These materials are provided by SAP SE or an SAP affiliate company for informational purposes only, without 
representation or warranty of any kind, and SAP SE or its affiliated companies shall not be liable for errors or omissions 
with respect to the materials. The only warranties for SAP SE or SAP affiliate company products and services are those 
that are set forth in the express warranty statements accompanying such products and services, if any. Nothing herein 
should be construed as constituting an additional warranty. 

In particular, SAP SE or its affiliated companies have no obligation to pursue any course of business outlined in this 
document or any related presentation, or to develop or release any functionality mentioned therein. This document, or 
any related presentation, and SAP SE’s or its affiliated companies’ strategy and possible future developments, products, 
and/or platform directions and functionality are all subject to change and may be changed by SAP SE or its affiliated 
companies at any time for any reason without notice. The information in this document is not a commitment, promise, or 
legal obligation to deliver any material, code, or functionality. All forward-looking statements are subject to various risks 
and uncertainties that could cause actual results to differ materially from expectations. Readers are cautioned not to 
place undue reliance on these forward-looking statements, which speak only as of their dates, and they should not be 
relied upon in making purchasing decisions. 
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1  BUSINESS SCENARIO  
 
1.1 Introduction 
With the introduction of SAP GUI for HTML for browser-based radio frequency (RF) devices in SAP 
S/4HANA 2021, you can modernize the look and feel of RF screens. You can now have an SAP Fiori-like 
design without the need to use ITSmobile. SAP GUI for HTML renders the ABAP Dynpros created in the RF 
framework directly in the browser on the RF device. With SAP GUI for HTML, you can also use SAP Screen 
Personas to personalize RF screens. This guide describes how you can set up SAP Screen Personas flavors 
for mobile RF devices working on SAP GUI for HTML.  
Note that you can't use the ITSMobile Visual Editor with SAP GUI for HTML. For SAP GUI for HTML, we 
recommend using SAP Screen Personas.  
 

  

https://wiki.scn.sap.com/wiki/display/HOME/ITSmobile+Visual+Editor
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2 OVERVIEW 
 
2.1 Radio Frequency in Extended Warehouse Management 
 
The radio frequency (RF) framework is the standard solution for mobile devices that allows you to display an 
SAP application on GUI-based devices and browser-based devices using ITSmobile or SAP GUI for HTML. 
The RF framework supports your warehouse in the following ways:  
 

• Decouples business logic from the physical presentation of application data on a selected presentation 
device 

• Supports a large variety of device sizes, device types, and data entry types 

• Provides appropriate forms of data presentation according to application data, device capabilities, and 
user preferences 

• Calls appropriate services according to resource inputs (such as verification/input data, keystroke, or 
logon request) 

• Enables personalized menus and screens 

• Enables flexible and user-friendly screen and flow-logic generation and modification 
 
For more information, see Radio Frequency Framework. 
 
2.2 SAP Screen Personas 
 
SAP Screen Personas is a personalization engine for Dynpro and Web Dynpro applications. You can use 
SAP Screen Personas to personalize and transform the user interface of SAP applications according to 
specific business needs. You can create role-specific screens (called flavors) that are managed by a central 
administrator. A flavor is a specific screen personalization applied to a particular transaction. If required, you 
can also allow users to create their own personalized look and feel for applications or transactions. 
Transactions can have more than one flavor, with each screen looking differently if desired. See chapter SAP 
Screen Personas Features in Combination with RF for flavor recommendations in the RF context. 
You can also use SAP Screen Personas to create scripts that automate processes within a transaction. 
 
For more information, see SAP Screen Personas. 
 
 

 
 

Simplified Architecture  

https://help.sap.com/viewer/TEST/9832125c23154a179bfa1784cdc9577a/latest/en-US/4d4fa477c9c20c7ae10000000a42189c.html
https://help.sap.com/viewer/product/SAP_SCREEN_PERSONAS/Current/en-US
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3 PREREQUISITES 
 

1. Extended Warehouse Management (EWM) in SAP S/4HANA 2021 (or later) with configured SAP GUI 
for HTML and a radio frequency (RF) user profile 

2. Installation of SAP Screen Personas following the relevant installation steps (see Installation Steps) 

3. SAP Screen Personas with the editor role (flavor developer) or administrator users (admin users) (see 
Configuring Authorizations and Roles) 

Note that this guide is not applicable for using the RF framework in combination with ITSmobile (SICF 
service RFUI). 

  

https://help.sap.com/viewer/9db44532734f4718b91e460c020307fe/Current/en-US/2908a543b9a54baf871937e45f243da8.html
https://help.sap.com/viewer/9db44532734f4718b91e460c020307fe/latest/en-US/85f8bbc7f0d04edda0a0ab2a1b8ac5d7.html
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4 STEP BY STEP PROCEDURES 
This chapter describes common steps to personalize radio frequency (RF) transactions using SAP Screen 
Personas. For restrictions for SAP Screen Personas in the context of the RF framework, see the next 
chapter SAP Screen Personas Features in Combination with RF. 
 

1. Start SAP GUI for HTML on a desktop PC to launch the SAP GUI for HTML service. 
 

We recommend using a Google Chrome browser. Don't follow these steps in the back-end system 
using classical SAP GUI. 

 
2. Log onto the RF environment with your RF user profile. 

 
On the SAP Easy Access screen, choose Logistics → SCM Extended Warehouse Management → 
Extended Warehouse Management → Execution → Log On to RF Environment (/SCWM/RFUI). 

 
You can ignore the header and footer area as they will be hidden automatically when logging onto 
the RF environment following the right URL (see SAP Note 3048632 and chapter Simulating a 
Device in a Browser):  

 
 
 

3. Enter the warehouse number, resource, and presentation device name: 
 

 
 

The default presentation device you enter determines which screens are used when working in the 
RF environment.  
In Extended Warehouse Management (EWM), you can display RF screens in portrait or landscape 
mode. The presentation profile setting for the device defines the screen format. For example, profile 
‘**’ - standard screens in landscape mode, profile ‘*2’ - standard screens in portrait mode. 

 
4. Create a flavor for the RF environment. 
 

a. Choose SAP Screen Personas to open the Flavor Manager. 

https://launchpad.support.sap.com/#/notes/3048632
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b. Choose Create Flavor in the flavor bar. Note that Create Flavor is available only in SAP GUI 
for HTML but not in SAP GUI for Windows, so you need to work in a browser. 

 
 

c. Enter a name and description for the flavor. 
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You've created a flavor and can now start personalizing your RF screens. 

 
 
4.1 Changing the Background Color 
 

1. Select the screen element for the background. 
2. Choose Fill & Background or right click and choose Background. 
3. Choose a color from the palette. 
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If you don’t get the expected result, please check chapter SAP Screen Personas Features in 
Combination with RF for restrictions in the RF context. 

 
4.2  Changing the Font Size or Color 
 

1. Select the element whose font size or color you want to change. 
2. Choose Decoration to change the font to bold, italics, or underlined. Choose Color to change the font 

color. 
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4.3 Hiding Fields 

 

1. Select the objects you want to hide. 

 
 

2. Choose Hide. 
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4.4 Changing Button Size and Moving Buttons 
 

1. Select the button whose size you want to change. 
2. Move the element borders or use the size palette. 
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3. Drag and drop the button to move it to where you want it. 
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For more information about buttons, see chapter 5 SAP Screen Personas Features in Combination with RF. 
 
4.5 Creating Themes 
 
You can use the Themes tool to make multiple changes at the same time. For example, you can change the 
font for all elements with the same settings. 
 

1. Choose Themes in the flavor bar. 

 
 

2. Choose Create New Theme and enter a name and description for the theme. 

 
 

3. Customize the various groups of screen elements. 
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Your changes are applied to all group elements, except those elements that are adjusted manually. 
 
4.6 Assigning Different Flavors to Different Users or User Groups 

 
You can assign a flavor to any user using transaction /PERSONAS/ADMIN as follows: 

  
1. Select Access Control > Users and select the user. 
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2. Go to the Flavors tab and add the required flavor from the Flavor Gallery. 
You can also specify a default flavor for the user. 

 
 
If you enable the selected PFCG role for SAP Screen Personas, you can assign a flavor to a group of users 
by role using transaction /PERSONAS/ADMIN. 

 
1. Select Access Control > Roles. 

 
 

2. Choose Create and select an existing PFCG role. 
3. Go to the Flavor Assignments tab and add the required flavor from the Flavor Gallery.  

 You can also specify a default flavor for the role. 
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Additionally, you can change the role assignment using Business Add-In (BAdI) Initialization of Flavor-Role-
Assignments (/PERSONAS/INIT_ROLE_ASSIGNMENT). For more details, see Manipulation of Flavor-Role-

Assignments Using BAdIs. 
 
For more information about customizing SAP Screen Personas, see the Administration Guide for SAP 

Screen Personas. 

 

4.7 Simulating a Device in a Browser 
 

After creating a flavor, you can check the result by simulating a device with the browser’s developer tools. 

The steps below describe how to do this for the Google Chrome browser. 

 

1. Call a URL that uses the following pattern: 
 
https://<server>/sap/bc/gui/sap/its/ewm_mobgui?~transaction=/scwm/rfui&sap

-language=EN 

 
Note that you can add your flavor from the previous steps by using the additional URL parameter sap-
personas-flavor with the ID of your flavor. You get the flavor’s ID in the Flavor Manager: 

 
 

Example of URL with flavor ID added: 
 

https://<server>/sap/bc/gui/sap/its/ewm_mobgui?~transaction=/scwm/rfui&sap

-language=EN&sap-personas-flavor=42010AEEC6991EDC9DA9E6D402B213CA 

 
2. Log onto the RF with your RF user profile. 

 
3. Open the developer tools using the Google Chrome menu in the browser window and selecting More 

Tools > Developer Tools.  

Alternatively, you can press Ctrl + Shift + I. 

https://wiki.scn.sap.com/wiki/display/Img/Manipulation+of+flavor-role-assignments+using+BAdIs
https://wiki.scn.sap.com/wiki/display/Img/Manipulation+of+flavor-role-assignments+using+BAdIs
https://help.sap.com/viewer/b6a24c359e2142e3a86ff405f43ba282/Current/en-US/84150519d95d42fb841795f9adb249d6.html
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4. Toggle to the device toolbar by selecting a corresponding button or pressing Ctrl + Shift + M: 

 

 
 

5. Select one of the devices, for example, Galaxy S5: 
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4.8 Scripting 
 

You can use scripting to automate or manipulate screen actions, for example: 
 

• Screens can be skipped assuming mandatory fields can be filled automatically by the script 

• Fields can be prefilled 
 

SAP Screen Personas scripts are small pieces of JavaScript. You can attach these scripts to individual UI 
elements with script events or entire screens with screen events. For more details, see Scripting. 
 
Note that the use of scripting can have negative side effects, for example: 

 

• Performance - there is a visible delay in the button changing color 

• If you want to change the color of a button depending on its content, the corresponding coding 
might become language dependent. That is, if the script checks for the label text, you must 
consider different languages used in your warehouses. 

 

4.8.1 Example 1 – Changing the Color of a Button 
 
The steps below describe how to create a script to change the color of the second button on the Pick-HU 
Creation screen in the RF logical transaction for picking. 

 
 

1. Start the script editor from the flavor bar by choosing Scripts > Edit: 
 

https://help.sap.com/viewer/20993a0c28654a26beb2b63b722d74f2/Current/en-US/8237dd539c11f76be10000000a44176d.html


SAP Screen Personas for Mobile RF Devices in EWM in SAP S/4HANA – How-to Guide  

 21 

 
2. Choose Create New Script: 

 
 

3. Name the script and create the following implementation in the coding window: 

 
 

if (session.idExists("wnd[0]/usr/subX:/SCWM/SAPLRF_PICKING_PM:0200")) { 
  if (session.idExists("wnd[0]/usr/btn/SCWM/S_RF_SCRELM-PB2")) { 
    session.findById("wnd[0]/usr/btn/SCWM/S_RF_SCRELM-PB2").setProperty("backgroundColor", 
"rgba(177,175,100,1)"); 
  } 
 
} else { 
  
 if (session.idExists("wnd[0]/usr/btn/SCWM/S_RF_SCRELM-PB2")) { 
   
  session.findById("wnd[0]/usr/btn/SCWM/S_RF_SCRELM-PB2").setProperty("backgroundColor", 
"rgba(40,223,118,1)");  
 } 
} 

 
 

4. Save the implementation. 
 

5. Assign the script to the screen event by editing the flavor, choosing the Insert tab, and choosing Script 
Events: 
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6. Add the created script to the onAfterRefresh screen event: 

 

 
 
When the script runs, the color of the second button on the Pick-HU Creation screen is changed: 

 

4.8.2 Example 2 – Dynamically Hiding the Verification Field on the Destination Screen 
The steps below use a script to dynamically hide the quantity fields on the destination screen of a product 
warehouse task in RF picking. Besides hiding the fields, the script also automatically verifies the quantity on 
the destination screen. This is based on the assumption that the quantity was already verified on the source 
screen. 
 

1. Start the script editor from the flavor bar by choosing Scripts > Edit: 
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2. Choose Create New Script: 

 
 

3. Add the following coding: 

 
 

// OnAfterRefresh 

 

if (session.idExists("wnd[0]/usr/subX:/SCWM/SAPLRF_PICKING_PM:0302/lbl/SCWM/S_RF_O

RDIM_CONFIRM-NISTA_VERIF")) { 

    session.findById("wnd[0]/usr/subX:/SCWM/SAPLRF_PICKING_PM:0302/txt/SCWM/S_RF_O

RDIM_CONFIRM-

NISTA_VERIF").text = session.findById("wnd[0]/usr/subX:/SCWM/SAPLRF_PICKING_PM:030

2/txt/SCWM/S_RF_ORDIM_CONFIRM-NISTA_CHR").text; 

    session.findById("wnd[0]/usr/subX:/SCWM/SAPLRF_PICKING_PM:0302/lbl/SCWM/S_RF_O

RDIM_CONFIRM-NISTA_VERIF").hide(); 

    session.findById("wnd[0]/usr/subX:/SCWM/SAPLRF_PICKING_PM:0302/txt/SCWM/S_RF_O

RDIM_CONFIRM-NISTA_VERIF").hide(); 

    session.findById("wnd[0]/usr/subX:/SCWM/SAPLRF_PICKING_PM:0302/txt/SCWM/S_RF_O

RDIM_CONFIRM-ALTME").hide(); 

}  

 
 

4. Save the implementation. 
 

5. Assign the script to the screen event by editing the flavor, choosing the Insert tab, and choosing Script 
Events: 
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6. Add the created script to the onAfterRefresh screen event: 

 

 
 

When the script runs, the quantity fields won't be visible on the destination screen for product warehouse 
tasks in RF picking: 

 

5 SAP SCREEN PERSONAS FEATURES IN COMBINATION WITH RF IN EWM 
 
When using SAP Screen Personas with radio frequency (RF) screens in Extended Warehouse Management 
(EWM), it's important to pay attention to the ID of the screen element that you're adjusting.  
 
RF screens have two main parts: 
 

• Template screen with buttons - this screen contains buttons with the element IDs 
/SCWM/S_RF_SCRELM-PB1 through to /SCWM/S_RF_SCRELM-PB4. 

• Subscreen area with dynamic content - the subscreen area is called based on the maintained 
screen and program for the current RF step in the RF customizing or the menu subscreen. 
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Template screen (White area) 

• Contains buttons  

• Contains subscreen area  

• Portrait mode - 15 rows and 26 
columns 

• Landscape mode - 8 rows and 40 
columns 

 
Subscreen area (Grey area) 

• Contains dynamic content 

• Portrait mode - 13 rows and 26 
columns 

• Landscape mode - 7 rows and 40 
columns 

 
If you adjust an element in the subscreen area, the changes are applied only for the transaction that uses 
this subscreen area. If you adjust a button of a template screen, the changes are applied to all RF 
transactions. 
 
Examples: 
 

• When applying changes to the RF menu items, the changes are applied to all the menu items (for 
example, Inbound Process, Outbound Process, and Internal Process) and subitems (for example, 
Picking, Packing, and Loading) because they have the same ID. They have the same RF 
transaction, same screen number, and same technical element.  

Subscreen Area 

Template Screen 
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• When applying changes for the buttons on the main screen, the changes are applied to all RF 
transactions because they have the same screen element IDs. 
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SAP Screen Personas allows you to adjust only screen elements that are displayed on a screen when the 
screen is being used. If some of the elements or screens are not displayed based on context (for example, 
serial numbers), you can't adjust these elements. Consequently, if you want to influence serial number fields, 
you have to work with a serialized product. To overcome this limitation, you can use design mode on a 
desktop to adjust RF screens more easily. 
 
With design mode, you can see all the RF screens in your current presentation format (portrait or landscape) 
and all possible fields that belong to the RF transaction, without needing to prepare the necessary data 
upfront.  
 
Tips: 
 

• Start design mode by pressing Ctrl + Shift + F2 from any screen in the RF transaction that you want to 
adjust.  

• Go to the next screen by pressing Ctrl + Shift + F3. 

• Return to the previous screen by pressing Ctrl + Shift + F4.   

• You can identify the screen you're adjusting by the description of the RF transaction and the RF 
transaction step in the header, for example, Picking by WO – Picking Source Material WT. 

• Start SAP Screen Personas by choosing Adapt UI to open the Flavor Manager. 

• End design mode by restarting the Test RF Environment app. 
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Example: RF Picking Screen 

Normal Mode - some fields hidden from RF transaction 
based on current application data  

Design Mode - all fields visible 

  

5.1 Creating SAP Screen Personas Flavors – Tips & Tricks 

• Before creating a flavor, it's important to think about which transactions and screens you want to 
adapt.  

• Optionally, you can create a custom radio frequency (RF) menu to limit the menu entries displayed 
(for example, to different users).  

• Extended Warehouse Management (EWM) provides the RF screens in two presentation formats 
(portrait and landscape mode). If you use RF devices with only one presentation format, make sure 
that you enter the right presentation device type at the RF logon screen. If you use RF devices with 
both presentation formats, you might have to make the SAP Screen Personas change twice. The 
latter depends on the usage of themes (see previous chapter). 

• When changing the content of the template screen (see chapter 5), check all the subscreens that 
you use. The layout change you make could negatively affect the subscreens. For example, if you 
increase the size of buttons on the top of the screen, you must rearrange the subscreen area so that 
it's not hidden by the content of the template screen. 

• SAP recommends preparing necessary test data for the screens that need to be adjusted. Then 
create an SAP Screen Personas flavor and apply to your RF screens as described in chapter 4. 

• Test your RF screens in a browser and then validate the flavor with a real RF device. Distribute the 
flavors to the relevant target system. For information about transports in relation to SAP Screen 
Personas, see the Administration Guide for SAP Screen Personas. 

• SAP recommends creating one flavor for the complete RF experience. Nevertheless, depending on 
your needs, it's also possible to create separate flavors, for example, for different user groups 
(experienced users as opposed to temporary employees) and application areas (inbound, outbound, 
and internal processes). 

6 RESULT OF SAP SCREEN PERSONAS FLAVOR  
 
In this video file, there's a demo of the result of an SAP Screen Personas flavor applied to the RF picking 
transaction. It compares the RF picking transaction with and without a custom flavor. 

https://help.sap.com/viewer/b6a24c359e2142e3a86ff405f43ba282/Current/en-US/03612496d0c6473d99749a0054d72d3b.html
https://sapvideoa35699dc5.hana.ondemand.com/?entry_id=1_vc17ip23
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7 USEFUL LINKS 
 

• SAP Screen Personas 
o Help Portal 
o Open SAP Course: SAP Screen Personas  
o Open SAP Course: Introduction to SAP Screen Personas 
o Open SAP Course: Using SAP Screen Personas for Advanced Scenarios 
o Open SAP Course: Building Mobile Applications with SAP Screen Personas 
o SAP Community 
o Blog posts on the SAP Community 

 

• Extended Warehouse Management 
o RF Cookbook 

https://help.sap.com/viewer/product/SAP_SCREEN_PERSONAS/Current/en-US
https://help.sap.com/viewer/product/SAP_SCREEN_PERSONAS/Current/en-US
https://help.sap.com/viewer/product/SAP_SCREEN_PERSONAS/Current/en-US
https://open.sap.com/courses/sps1
https://open.sap.com/courses/sps1
https://open.sap.com/courses/sps1
https://open.sap.com/courses/sps2
https://open.sap.com/courses/sps2
https://open.sap.com/courses/sps2
https://open.sap.com/courses/sps3
https://open.sap.com/courses/sps3
https://open.sap.com/courses/sps3
https://open.sap.com/courses/sps4
https://open.sap.com/courses/sps4
https://open.sap.com/courses/sps4
https://community.sap.com/topics/screen-personas
https://community.sap.com/topics/screen-personas
https://community.sap.com/topics/screen-personas
https://blogs.sap.com/tags/67838200100800005412/
https://wiki.scn.sap.com/wiki/download/attachments/451060111/RF_Cookbook.pdf?api=v2
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